cancel
Showing results for 
Search instead for 
Did you mean: 
smarthacker67
Paper Tape
Posts: 3
Registered: ‎10-17-2015
Location: mumbai
Views: 1,183

y50-70 touchpad issue unable to install elan drivers

Hi,

i am facing a strange problem from last few months(my multifingure touch,scrolling etc every action from utility is not working). i have touchpad of elan but system detects it as synaptics always. whenever i am trying to install new driver or reinstall (via system update or by direct running setup ) system always ended up installing synaptics driver.
my touchpad and keyboard was replaced for issue with right click and the previous part was having touchpad from synaptics along with windows 8.1. after replacing that part i have updated to winodws 10. Lenovo enineers have also visited for same issue but no luck they tried updating bios,removing and installing new driver several times and later ended up chnaging the keyboard and touch pad with new one but still no luck.
again same issue this time also they have replaced with elan touch pad but sytem always detects it as synaptics. can you help me ?

 

currently i have unistaaled every driver and working on windows driver.

making it difficult for me to use scrolling ,multitouch etc.

 

Thanks

Who Me Too'd this topic