cancel
Showing results for 
Search instead for 
Did you mean: 
Angulion
Fanfold Paper
Posts: 21
Registered: ‎01-24-2016
Location: Germany
Views: 14,863

P50 Win 10 Pro -- Fingerprint stopped working

Dear all,

 

I've just received my P50 (20EQS00600, M1000M, i7-6700HQ, 16 GB RAM, 512 GB SSD) about a week ago, and I quite like it. However, there is one thing that is driving me nuts: after I upgraded from Win 7 Pro 64 bit to Win 10 Pro, the fingerprint functionality stopped working. This issue seems to be related to the ones reported in these two threads for the P70 but at the same time appears sufficiently different to warrant a new post:

 

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/P70-fingerprint-software-issue/m-p/22517...

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/Fingerprint-and-Sound-problems-P70/td-p/...

 

So, here's what I did:

1) I clean-installed Win 10 w/o retaining any data/settings from the previous Win 7 installation; I even reformatted the SSD.

2) Upon initial installation I was asked by Windows Hello to enroll fingerprints which I did.

3) Fingerprint worked on the first login but then magically vanished. Windows Hello is no longer showing up as a login option in the Win control panel.

4) I discovered in Device Manager that the Synaptics WBDI reports the following problem: 'This device cannot start. (Code 10)'.

5) Repeated uninstall and reinstall of the drivers are to no avail. I tried both having Win look up a driver and manual installation of the drivers I downloaded from the Lenovo page.

6) When I uninstalled the drivers and then wiped the stored fingerprints in BIOS, I was again able to enroll fingerprints with Windows Hello. However, this time the fingerprints were not even registered in Windows, and I had to cancel the procedure. Immediately after, the Synaptics driver stopped working, cf. 4).

 

I am at a loss what to do. Strange thing is that I ran Win 7 for about a week, and the fingerprint reader worked fine all the time. (Due to scaling issues on my 4k display I bit the bullet and went to Win 10, in case you are wondering.)

 

So, anybody out there experiencing the same problem, anybody having a solution?

 

Thank you in advance and best,

A

Who Me Too'd this topic