cancel
Showing results for 
Search instead for 
Did you mean: 
Tudorific
Paper Tape
Posts: 2
Registered: ‎06-18-2016
Location: CA
Views: 1,361

Lenovo Y40 Battery Issues

Hi,

 

I am having some battery issues with my Y40 laptop which I purchased in late 2014. It seems that the battery gauge reads 100% even though the battery is discharging and the power cable is not plugged in. I have tried completely draining the laptop and charging it again, when charging from 0% it does update the percentage correctly on the battery gauge.

 

However, after I close the laptop lid and it goes to sleep, if I open it again, it reads 100% even though I know its not at 100%. Then it just dies after it discharges but I have no idea when to plug it in since I can't trust the gauge.


Any ideas what could be causing this? I had a similar issue in the past and sent it back to Lenovo and they replaced the battery but could it really be the battery again after only 8 months of usage? The battery holds a charge fine, it just doesn't update the battery gauge on the taskbar properly it seems.

 

I've gotta say, if thats the case, I'm quite dissapointed in this laptop Smiley Sad.

 

I read a bunch of the other posts online about similar issues but nothing specific to this laptop that has fixed the issue. I'm not sure what else to try and if there is something else I can do.

 

Note that I am running Windows 10 instead of 8.1 which is what the laptop came with initially.

 

Thanks for the help!

Who Me Too'd this topic