cancel
Showing results for 
Search instead for 
Did you mean: 
wshamroukh
Paper Tape
Posts: 5
Registered: ‎10-20-2009
Location: UAE
Views: 4,626

Yoga X1 touch screen driver is not working - not getting installed

Hi all,

 

I am hoping i could find someone how could help me with the touch screen issue on my brand new Yoga X1.

I have Windows 10 x64 installed on it. The touch screen is not working. In device manager i see a yellow mark on the Pen/Touch driver. Checking the status of the driver, I see the following error:

 

The drivers for this device are not installed. (Code 28)

Driver is not intended for this platform.


To find a driver for this device, click Update Driver.

 

If i initiate Driver Update, i still get the same error:Driver is not intended for this platform.

 

This event is logged while getting the driver installed:

 

Log Name: System
Source: Microsoft-Windows-UserPnp
Date: 3/20/2017 10:15:58 PM
Event ID: 20001
Task Category: (7005)
Level: Information
Keywords:
User: SYSTEM
Computer: YOGA
Description:
Driver Management concluded the process to install driver isd_infinstall.inf_amd64_6328f9bbe4ff72f6\isd_infinstall.inf for Device Instance ID USB\VID_056A&PID_5040\5&1DAC11DF&0&10 with the following status: 0xE0000234.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-UserPnp" Guid="{96F4A050-7E31-453C-88BE-9634F4E02139}" />
<EventID>20001</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>7005</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2017-03-20T18:15:58.907145400Z" />
<EventRecordID>1706</EventRecordID>
<Correlation />
<Execution ProcessID="5228" ThreadID="9840" />
<Channel>System</Channel>
<Computer>YOGA</Computer>
<Security UserID="S-1-5-18" />
</System>
<UserData>
<InstallDeviceID xmlns="http://manifests.microsoft.com/win/2004/08/windows/userpnp">
<DriverName>isd_infinstall.inf_amd64_6328f9bbe4ff72f6\isd_infinstall.inf</DriverName>
<DriverVersion>7.3.4.25</DriverVersion>
<DriverProvider>Wacom Technology</DriverProvider>
<DeviceInstanceID>USB\VID_056A&amp;PID_5040\5&amp;1DAC11DF&amp;0&amp;10</DeviceInstanceID>
<SetupClass>{745A17A0-74D3-11D0-B6FE-00A0C90F57DA}</SetupClass>
<RebootOption>false</RebootOption>
<UpgradeDevice>false</UpgradeDevice>
<IsDriverOEM>true</IsDriverOEM>
<InstallStatus>0xe0000234</InstallStatus>
<DriverDescription>Wacom Device</DriverDescription>
</InstallDeviceID>
</UserData>
</Event>

 

I even downloaded the driver from the support site, but again it fails with the same error.

 

I am sure there something wrong with this driver.

 

Has anyone suggestion for me how to get this escalated to lenovo?

 

Who Me Too'd this topic