cancel
Showing results for 
Search instead for 
Did you mean: 
Petemelster
Paper Tape
Posts: 1
Registered: ‎05-10-2018
Location: US
Views: 15,302

Yoga 920 won't charge anymore

So I've only had my yoga 920 for 1 or 2 months now.

 

But one day, the charger stopped working. It was plugged in but not charging the laptop at all. The battery icon showed it was on battery power, like the laptop didn't even realize it was plugged in. I tried both USB-C ports also, but neither helped my laptop charge.

 

SoI'm not talking about the "plugged in, not charging" text I've seen show up in some laptops before.

 

Right now, the laptop just doesn't realize it's plugged in at all.

Even the  charging LED was not on, despite being plugged in.

 

Lenovo sent me a new charging adaptor, so we'll see if that works.

 

In the last 3 days, I've just been using a USB-C phone charger to charge the laptop, which worked with both USB-C ports. Obviously the speed was slow, so if I did intensive tasks, the laptop drained faster than it charged, but it was charging.

 

However, today, the laptop refused to charge with both ports with this phone charger. Again, the laptop did not recognize it was plugged in and the charging LED was not on, despite being plugged in.

 

I thought the laptop itself must be frying all chargers, but I tried the charger with a phone, and the phone started charging. So it seems the charger is fine, but the laptop won't charge!

 

Any solutions or idea what caused two chargers to suddenly stop working? The Lenovo laptop charger itself is dead, but the phone charger works (just no longer to charge the laptop).

 

Is some internal hardware circuity messed up?

Who Me Too'd this topic