cancel
Showing results for 
Search instead for 
Did you mean: 
Cracken
Paper Tape
Posts: 4
Registered: ‎07-24-2018
Location: HR
Views: 14,191

Yoga 910 plugged in not charging

Hello,

 

I have bought 910 and reinstall with fresh 1803. I have upgrade bios to latest and installed all drivers from support page.

using OEM charger and using proper port for charging (rear). Also device is ok with charger because i can charge tablet when it is turn off. Even in bios it is charging, so i know that there are problem with drivers in windows.

Scenario is like this:

 

1. If i boot with charger pluged in 

  • i have exclamation mark in device manager (I2C HID Device) - last pic
  • It says that is is charging but after minute of charging battery indicator stops, (still says charging - but it does not). 2 nd pic
  • After removing charger and plugin again says only plugged in NOT CHARGING. 1st pic.

 

 

lenovop1-2.PNGlenovop1-1.PNGlenovop1.PNG

 

2. If i plug in charger after boot i have:

 

  • no exclamation mark in device manager
  • rest is same as above example.

 

I tried all drivers (which are kind very OLD) , tried Lenovo Vintage (ussless), tried drivers from 920 .. same. Three times i have reinstalled windows even with generic microsoft drivers, it does NOT CHARGE.

 

Also there is annoying screen flickering which i sloved by manually add driver from 920. (not completly still shows sometimes.)

 

will try linux and if that will not work, i am going to return this expensive toy. Funny that i wanted to buy X1 Carbon soon... lol 

guessing that problem is in Windows changing from ver to ver. and Lenovo, who does not update neither drivers or bios. Sad....

Who Me Too'd this topic