cancel
Showing results for 
Search instead for 
Did you mean: 
Reier
Paper Tape
Posts: 3
Registered: ‎09-01-2018
Location: NO
Views: 3,998

Lenovo tab 4 10 plus 5GHz bug

After using a lot of time solving a keyboard problem for connecting the standard recommended external keyboad and also problems with the default keyboard (another entry in this forum), I thought everything was OK with this tablet. (The default keyboard installed could not be used, so I had to download another keyboard and that solved this problem).

But no, when surfing on internet, the wireless WIFI connection 5GHz was disconnected after a while (sometimes after 20 seconds, sometimes after 20 minutes). The problem often occured when browsing  a slow internet site, but the disconnect was permanent. So I had to turn off wifi and turn it on again to fix this problem.

After searching this forum and on internet, I found that there was a reference to a recent bug using the 5GHz band, due to a recent firmware update. Today I used a couple of hours to change the setup of the Wifi router, to use a separate name for the 5GHz band and the 2.4GHz band. I noticed that the tablet first tried to connect to 2.4GHz and then to 5 GHz, and I thought maybe two connections could cause interference or something. But no, the problem happened even after I connected to 5GHz with the new wifi network name.

What I did then was to connect to the 2.4GHz network with a changed name. In that way the tablet would not try to connect to the 5GHz network. It seems like this solved the problem. What I also noticed was the the internet speed was the half of what it used to be, but that was expected too.

But Lenovo: I have checked the specs of the tablet Lenovo TB-x704F and it should support the 5GHz band. So what I have bought is actually a malfunctioning device (a software bug in the firmware is also a malfunction). What is Lenovo going to do about this? I really should get the money back when returning the device to there I bought it (Dustin), or Lenovo should repair this in some way, by a new firmware upgrade. 

 

I have used my other devices (Laptop, Samsung Phone, Iphone) connecting to my WLan without these problems, so this is a Lenovo Tablet problem only.

 

Luckily my home network supported both the 2.4GHz band and the 5Ghz band and I was able to fix the problem at home. But what if I try to connect the tablet somewhere with access to 5GHz only. A tablet of this type if useless if Wireless Lan cannot be used. 

 

I will not really recommend using Lenovo products to anyone. This is not the first time I have used a Lenovo device and problems like that has occured. In my job a got a Lenovo Thinkpad PC. This labtop typically shut down (bluescreen) twice a week. I was told it was a Bios problem. After 4 months I finally got a Bios upgrade (A second upgrade, the first did not fix this) that fixed this problem. But before that I lost parts what I was working on on the PC several times. And this was an expensive PC $2000 or something like that. Lenovo must take their customers more seriously, and test their software properly before installing it on a device.

 

best regards from Hans Reier Sigmond, Software developer /test automation expert / Project Manager Ciber Norway.

Who Me Too'd this topic