English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics
Options

8 Posts

08-26-2010

Honolulu

49 Signins

117 Page Views

  • Posts: 8
  • Registered: ‎08-26-2010
  • Location: Honolulu
  • Views: 117
  • Message 1 of 4

X201 Won't Boot: Blinking Cursor

2010-08-26, 21:43 PM

Hello,

 

This is my second post on this topic. The system in question is a brand new X201 Tablet PC, quad core. I purchased it specifically because Lenavo has full support for XP - I have been telling others how great Lenavo is about XP support - drivers, OEM utilities, everything fully working and supported on XP. Lenavo even has a Intel Turbo Boost "driver" for XP so it does not show as a "yellow bang" in the Device Manager. I appreciate all this.

 

Now, the problem: When I insert my XP boot drive, the BIOS will not boot off of the drive. The BIOS does access the drive and can see it/test it properly. I have tried this with the same system image using both an SSD and a mechanical drive, so I know it is not a drive issue. It is also not a driver issue, I actually have the necessary AHCI drivers installed on my XP installation, and I also tried it with SATA set to compatibility mode.

 

The same XP drive works just fine on any other computer - including Sager desktop replacements, Alienware m11x, HP TX2Z tablet, among others. Re-installing everything is NOT an option, this production XP image has been used since 2007 and has seen countless hours of installation, application configuration, and many other settings that would cost more in time than the amount paid for the X201 Tablet.

 

The BIOS does not even "bother" to read the boot sector or something. I really need this working. Is there a fix for the BIOS? Is there something that needs to be done to the XP drive (NOT a new install, but an EXISTING install) to fix it? Please, help! At the very least, if this issue cannot be resolved, I am hoping Lenavo will authorize a full refund on my system. I have all original parts and packaging. The system, as of this writing, is under 24 hours old.

 

Mimar

Reply
Options

1 Posts

08-27-2010

United States

1 Signins

18 Page Views

  • Posts: 1
  • Registered: ‎08-27-2010
  • Location: United States
  • Views: 18
  • Message 2 of 4

Re: X201 Won't Boot: Blinking Cursor

2010-08-27, 15:44 PM

I've got 3 X201s that really act funny when it comes to working with the PE recovery partition and my PE utilities. In order to get them to boot  Preinstall Environments we change the SATA configuration to compatibility in BIOS once we have done what we need to do in the PE we have to change them back to AHCI to boot into the pre-installed operating system.  You might try changing this setting and see if it makes a difference for you.

Reply
Options

8 Posts

08-26-2010

Honolulu

49 Signins

117 Page Views

  • Posts: 8
  • Registered: ‎08-26-2010
  • Location: Honolulu
  • Views: 117
  • Message 3 of 4

Re: X201 Won't Boot: Blinking Cursor

2010-08-27, 22:51 PM

Like I have already written in my post to which you responded to; I have tried both AHCI and ATA modes; this does not make a difference unfortunately.

Reply
Options

8 Posts

08-26-2010

Honolulu

49 Signins

117 Page Views

  • Posts: 8
  • Registered: ‎08-26-2010
  • Location: Honolulu
  • Views: 117
  • Message 4 of 4

Re: X201 Won't Boot: Blinking Cursor

2010-08-28, 23:25 PM

There is still no reply to this request; I can only conclude that there is no fix to this BIOS issue. Very unfortunate, my X201 also has a hardware problem with the tablet display (over sensitive and thinks there is contact on the surface when the pen is actually hovering above the surface), it seems my dreams of having a quad core tablet are destined to be unfulfilled.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save