Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: X Series Laptops
All Forum Topics

2 Posts


United States of America

2 Signins

42 Page Views

  • Posts: 2
  • Registered: ‎10-26-2019
  • Location: United States of America
  • Views: 42
  • Message 1 of 1

6th gen, headset microphone not detected in 3.5mm

2019-10-26, 1:32 AM

My Caron X1 6th gen, is not reliably detecting headset microphones in the 3.5mm jack.

I have two headsets, and two laptops.

One laptop is a Lenovo Carbon X1 6th gen, with Windows 10. It is only able to detect the microphone for one of my 3.5mm headsets.

The other laptop is a Dell 7530, it is able to recognize the microphone on both of my 3.5mm headsets (and they both work).


One difference with the Dell is that it has a software loaded (Wave Audio Pro) that prompts for you to select headset or headphones.

However, I suspect that Lenovo Carbon X1 RealTek audio driver does an impedance test or similar to detect the microphone and since different microphones have different impedances it will miss some and get others. Indeed I've seen hints in the registry with keys with 'ohm' in their name for the RealTek driver.


Of course I've tried the latest drivers, and some older drivers, and Windows trouble shooting.


So I want a solution that will either allow both of my headsets' microphones to be detected, OR a means to override the behavior and force the microphone pin in the 3.5mm port to be enabled. I've looked into a bunch of registry settings, but so far nothing has worked.


Something like Dell's software which prompts upon 3.5mm insertion "is this a headset, or headphones" would be great.

thanks - Mark


Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop





No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All