Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

7 Posts

03-11-2010

United States of America

30 Signins

160 Page Views

  • Posts: 7
  • Registered: ‎03-11-2010
  • Location: United States of America
  • Views: 160
  • Message 1 of 12

TV System Update fails to start

2010-03-11, 5:12 AM

Hi,

I'm running Vista SP2 32-bit on a T500.  Several months ago, TV System Update (v3.14) began to fail on startup.  The splash screen just flashes and hangs and it's difficult to stop it from within the Task Manager, so I have to reboot.  I have uninstalled System Update, cleaned the registry, reinstalled a newly downloaded copy and I've even installed the patch recommended for Vista SP2 somewhere in this forum.  I've also stopped and restarted the service within Administrator Tools.  None of this has resulted in getting past the flashing, hung splash screen.  It's driving me a little nuts.

 

The ServiceStart.log reads as follows:

 

Start service
The flag of monitor registry: False


The tvsu_exe.log reads as follows:

 

TSS(L) 1: 11:00:12:0716 tvsu.cpp(516): StartTvsukernel : admin
TSS(L) 1: 11:00:12:0718 tvsu.cpp(523): Begin InvokeUacSdkViaService
TSS(L) 1: 11:00:13:0796 tvsu.cpp(368): Installdir:  C:\Program Files\Lenovo\System Update
TSS(L) 1: 11:00:13:0798 tvsu.cpp(403): szCmd:  C:\Program Files\Lenovo\System Update\TvsuCommandLauncher.exe
TSS(L) 1: 11:00:18:0421 tvsu.cpp(516): StartTvsukernel : admin
TSS(L) 1: 11:00:18:0423 tvsu.cpp(523): Begin InvokeUacSdkViaService
TSS(L) 1: 11:00:19:0572 tvsu.cpp(368): Installdir:  C:\Program Files\Lenovo\System Update
TSS(L) 1: 11:00:19:0574 tvsu.cpp(403): szCmd:  C:\Program Files\Lenovo\System Update\TvsuCommandLauncher.exe
TSS(L) 1: 11:00:23:0713 tvsu.cpp(516): StartTvsukernel : admin
TSS(L) 1: 11:00:23:0722 tvsu.cpp(523): Begin InvokeUacSdkViaService
TSS(L) 1: 11:00:24:0911 tvsu.cpp(368): Installdir:  C:\Program Files\Lenovo\System Update
TSS(L) 1: 11:00:24:0915 tvsu.cpp(403): szCmd:  C:\Program Files\Lenovo\System Update\TvsuCommandLauncher.exe
TSS(L) 1: 11:00:29:0498 tvsu.cpp(516): StartTvsukernel : admin
TSS(L) 1: 11:00:29:0505 tvsu.cpp(523): Begin InvokeUacSdkViaService
TSS(L) 1: 11:00:30:0679 tvsu.cpp(368): Installdir:  C:\Program Files\Lenovo\System Update
TSS(L) 1: 11:00:30:0681 tvsu.cpp(403): szCmd:  C:\Program Files\Lenovo\System Update\TvsuCommandLauncher.exe
TSS(L) 1: 11:00:35:0330 tvsu.cpp(516): StartTvsukernel : admin

 

...ad infinitum.

 

What can I try next?

 

Thanks in advance for any thoughts.  I've not found any other suggestions on these boards to solve the problem.

Reply
Options

1593 Posts

07-17-2009

Slovakia

576 Signins

12029 Page Views

  • Posts: 1593
  • Registered: ‎07-17-2009
  • Location: Slovakia
  • Views: 12029
  • Message 2 of 12

Re: TV System Update fails to start

2010-03-11, 20:17 PM

Hi,
go to windows services and find the services called "System Update". Open the properties of this services and go to the Log on tab. Make sure, that the "Local Systems account" is selected. Then go to Recovery tab and make sure taht by all 3 options is "Restart the Services" selected.
Let me know, if that helps.
Also check the Windows Event log if there is any note, what might be wrong.

Cheers

Reply
Options

7 Posts

03-11-2010

United States of America

30 Signins

160 Page Views

  • Posts: 7
  • Registered: ‎03-11-2010
  • Location: United States of America
  • Views: 160
  • Message 3 of 12

Re: TV System Update fails to start

2010-03-11, 22:03 PM

Thanks for the suggestion Herik.  Unfortunately it didn't solve my problem.  I change 2 of the 3 options under the services recovery tab so that all 3 were set to 'restart the services.'  Local systems account was already selected, but I did get a user account control dialog before the TVSU began its endless loop of flashing the splash screen.  I never got a user account control authorization dialog before.  Maybe you're onto something...

 

I'm not sure what to look for in the Windows Event Log.  Should I look for notices that have TVSU (or something similar) listed as the source?

 

Thanks again.

Reply
Options

20 Posts

09-26-2008

New Mexico

79 Signins

335 Page Views

  • Posts: 20
  • Registered: ‎09-26-2008
  • Location: New Mexico
  • Views: 335
  • Message 4 of 12

Re: TV System Update fails to start

2010-03-12, 13:35 PM

Just to chime in, I am having the same expereince with System Update on a T410 running Windows 7 Pro 64 bit and have tried roughly the same set of interventions wihtout success....

Reply
Options

7 Posts

03-11-2010

United States of America

30 Signins

160 Page Views

  • Posts: 7
  • Registered: ‎03-11-2010
  • Location: United States of America
  • Views: 160
  • Message 5 of 12

Re: TV System Update fails to start

2010-03-14, 18:29 PM

More info...

 

I am not using the original version of Vista that came on the laptop.  I had to upgrade to Vista Ultimate 32-bit to run some software that i need.  So it's no longer the original Lenovo image.

Reply
Options

1593 Posts

07-17-2009

Slovakia

576 Signins

12029 Page Views

  • Posts: 1593
  • Registered: ‎07-17-2009
  • Location: Slovakia
  • Views: 12029
  • Message 6 of 12

Re: TV System Update fails to start

2010-03-15, 21:23 PM

Hi,

if this situation is still present, then try to completely uninstall TVSU and install it back again.

Might be possible, that something went wrong during the installation.

 

Let me know, if you have any more info to this .

 

Cheers

Reply
Options

7 Posts

03-11-2010

United States of America

30 Signins

160 Page Views

  • Posts: 7
  • Registered: ‎03-11-2010
  • Location: United States of America
  • Views: 160
  • Message 7 of 12

Re: TV System Update fails to start

2010-03-15, 21:48 PM

I have done 3 reinstalls of TVSU already and each has resulted in the same outcome as the original.  I am afraid there is some aspect of Vista, perhaps the result of an update along the way, that will not allow TVSU to open and run properly.

 

I recently attempted to install TV Toolbox, thinking that this may have some functionality overlap with TVSU.  Toolbox would not install properly at all.  It hung in a different place each time, but failed each time to complete installation even given hours.  I now cannot uninstall it using its 'uninstall' feature either.

Reply
Options

12 Posts

05-21-2008

Anaheim, CA

45 Signins

130 Page Views

  • Posts: 12
  • Registered: ‎05-21-2008
  • Location: Anaheim, CA
  • Views: 130
  • Message 8 of 12

Re: TV System Update fails to start

2010-03-19, 19:50 PM

Windows 7, 32 Bit, Lenovo T60..... same issue, Launch System Update 4, splash screen appears, splash screen disappears....

 

Is there a fix for this?

Reply
Options

7 Posts

03-11-2010

United States of America

30 Signins

160 Page Views

  • Posts: 7
  • Registered: ‎03-11-2010
  • Location: United States of America
  • Views: 160
  • Message 9 of 12

Re: TV System Update fails to start

2010-03-19, 21:12 PM

No fixes yet, as far as I'm aware.

Reply
Options

1593 Posts

07-17-2009

Slovakia

576 Signins

12029 Page Views

  • Posts: 1593
  • Registered: ‎07-17-2009
  • Location: Slovakia
  • Views: 12029
  • Message 10 of 12

Re: TV System Update fails to start

2010-03-24, 20:10 PM

Hi,

I have seens situation, with the splash screen pupping up and then directly going away. This was mostly due to missing .NET 2.0 . So can you confirm, that you have all the version of .NET intsalled from 1.1 up to 3.5?

 

Can you see anything in the Windows event log about this situation?
Also try to download the debugview:

http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx

(enable Capture\Win 32; capture Kernel and the rest might also help. )

start it and try to start TVSU and let me know, if this will bring up any info.

 

Make sure, that you have following files and folders :

%ProgramFiles%\Lenovo\System Update\resources

%ProgramFiles%\Lenovo\System Update\resources\defaultbillboard

%ProgramFiles%\Lenovo\System Update\resources\noTranslated

%ProgramFiles%\Lenovo\System Update\resources\translated

%ProgramFiles%\Lenovo\System Update\egather

%ProgramFiles%\Lenovo\System Update\egather\MetaData.xml

 

These are the locations, from where TVSU reads the informations on the system and the startup.

If I were you I would also run the

%ProgramFiles%\Lenovo\System Update\egather\IA.exe

which will create a new .XML file, which should list the content of your system. Once you have it, check if especially the OS and the system type is correct.

 

Let me know any infor on this topic. It seems pretty strange to me, but I bet, that this is only a missconfiguration, or a file is missing/blocked in the system.

 

Cheers

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms