English Community

Linux Operating SystemsOther Linux Discussions
All Forum Topics
Options

4 Posts

05-19-2020

US

4 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎05-19-2020
  • Location: US
  • Views: 50
  • Message 1 of 3

X270 unable to boot from USB

2020-05-20, 16:08 PM

When I get to the boot menu, the USB drive (Linux, SATA3) is available as an option.  When I select it (press enter), the screen flashes blank for a split-second, then returns to the boot screen.

 

"Secure Boot" is disabled.


The Win10 disk (NVMe) that came with the unit, booted without issues.

 

I have tried the exact same procedure, with an X250 I own, and it boots (over USB) without problem.

 

 

 

Anyone have an idea of what is wrong?

Solved! See the solution
Reply
Options

8359 Posts

01-13-2008

US

77299 Signins

2194489 Page Views

  • Posts: 8359
  • Registered: ‎01-13-2008
  • Location: US
  • Views: 2194489
  • Message 2 of 3

Re:X270 unable to boot from USB

2020-05-20, 16:13 PM

How was the drive prepared and what exactly is on it?  Are you booting in UEFI or legacy mode?  Is the drive intended to boot in UEFI or legacy mode, or both?

 

Are you talking about an external drive - flash drive or other - or an internal drive?  You mention both USB and SATA3 so it's a bit confusing.

 

More information please.

 

Z.


The large print: please read the Community Participation Rules before posting. Include as much information as possible: model, machine type, operating system, and a descriptive subject line. Do not include personal information: serial number, telephone number, email address, etc.


The fine print: I do not work for, nor do I speak for Lenovo. Unsolicited private messages will be ignored - questions and answers belong in the forum so that others may contribute and benefit. ... GeezBlog

 

Communities: English Deutsch Español Português Русскоязычное Česká Slovenská Українська Polski Türkçe Moto English

Reply
Options

4 Posts

05-19-2020

US

4 Signins

50 Page Views

  • Posts: 4
  • Registered: ‎05-19-2020
  • Location: US
  • Views: 50
  • Message 3 of 3

Re:X270 unable to boot from USB

2020-05-20, 16:29 PM

@ zoltanthegypsy wrote:
 

 

How was the drive prepared and what exactly is on it?  Are you booting in UEFI or legacy mode?  Is the drive intended to boot in UEFI or legacy mode, or both?

 

Are you talking about an external drive - flash drive or other - or an internal drive?  You mention both USB and SATA3 so it's a bit confusing.

 

More information please.

 

Z.

 

You are completely on the right track.  The BIOS was set to UEFI-Only.  After setting it to "Both" (allowing Legacy Mode) and rebooting, the POST screen came up.  Drive detected (after a slight pause).  Then the screen goes blank with a cursor at the top-left.  Then screen-depowers, because I think the computer is rebooting.  POST shows up again.  Drive was instantly detected.  Now the USB drive is boots correctly.

 

The USB drive in question is a former internal SATA3 drive (from the X250), put into an external USB enclosure running Linux.

 

So, the short form . . .

 

SOLUTION: make sure BIOS is set to support booting in Legacy Mode.

 

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete